Fehler beim Start von Certificate und bei Neuinstallation

Fehlerbeschreibungen bitte hier posten.

Moderator: admin

Antworten
Holger
Beiträge: 2
Registriert: So Mai 27, 2012 9:18 am

Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von Holger »

Hallo zusammen,

hatte zunächst den selben Fehler, den Klaus am 17. April gepostet hat: beim Start von Certificate erscheint die Fehlermeldung

Laufzeitfehler -2147221231 (80040111)
Automatisierungsfehler
ClassFactory kann angeforderte Klasse nicht liefern.

Allerdings nutze ich die aktuelle Version 2.0.10 und Windows 7 Ultimate. Vor der Aktualisierung auf die neue Version lief Certificate problemlos

Ich bin den Tipps gefolgt, die ihr Klaus gegeben habt und habe die Version nochmals installiert. Dabei war ich als Administrator angemeldet und habe sowohl Track and Field, wie auch Certificate erstmals als Administrator gestartet. Diese Maßnahmen halfen jedoch - im Unterschied zu Klaus - nicht.
Abschließende habe ich noch einen Versuch gestartet: Ich habe Track and Field vollständig deinstalliert, um es von Grunde auf neu anzulegen. Nach Start des Installationsprogramms erscheint nach 3% folgende Fehlermeldung (die ich leider nicht vollständig lesen kann):

Fehler bei Komponentenübertragung
Komponente: Program Files
Dateigruppe: Additional Programfiles
Datei: C:\Program Files\Seltec Sport\Seltec Track and
Field\Layouts\
Beschreibung: Zugriff verweigert

Klingt nach einem Rechte-Problem. Der Fehler erscheint jedoch sowohl, wenn ich als Administrator, wie auch wenn ich als normaler Nutzer angemeldet bin. Er trat nicht auf, als ich Track and Field jeweils aktualisiert habe (weder als Administrator noch als User).

Hat jemand eine Idee, wie ich die beiden Fehler beheben kann?

Würde mich freuen

Danke
Holger

DiWa
Site Admin
Beiträge: 474
Registriert: Mi Sep 21, 2005 9:53 pm
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von DiWa »

Rechte-Problem unter Windows 7 ist schon mal ein Hinweis.
Die Ursache könnte eine ähnliche sein, wie unter http://wiki.seltec-sports.de/doku.php?id=taf_windows7 beschrieben.

Hast Du die Deinstallation auch als Admin vorgenommen?
Wenn nein, bitte das nochmal probieren.
Vor der Neu-Installation schauen, dass das Verzeichnis von T&F komplett leer ist.
Und (WICHTIG) auch schauen, dass die im WIKI-Artikel beschriebenen virtuellen Verzeichnisse auch leer sind.
Danach die Installation starten.

Sollte das alles nicht helfen, kontaktiere mich bitte per Mail oder PM.

Merci

Dirk

Holger
Beiträge: 2
Registriert: So Mai 27, 2012 9:18 am

Re: Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von Holger »

Hallo Dirk,

Danke für die Hilfe,

damit hat es geklappt - sowohl die Neuinstallation wie auch der Start von Certificate haben nach dem Entfernen der verstecketen Ordner funktioniert. Es war zwar ein wenig Aufwand, die Daten zunächst alle zu sichern und dann aber zurückzuspielen, aber es geht jetzt. Kommt das jetzt bei jeder Aktualisierung auf mich zu?

Danke jedenfalls für die Hilfe

Holger

DiWa
Site Admin
Beiträge: 474
Registriert: Mi Sep 21, 2005 9:53 pm
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von DiWa »

Freut mich, dass es jetzt klappt.

Das Problem ist, dass der Installer diese virtuellen Verzeichnisse nicht "kennt" und deshalb dort keine Daten löschen kann.
Windows kopiert die Dateien dort bei der ersten Verwendung hin - so dass auch ein Installationslog nichts hilft.
U.U. sind da ja auch mehrere (für verschiedene User-Accounts) installiert.
Bei Wettkampfdatenbanken oder Urkundenlayout kann man sich helfen, indem man sie in einen öffentlich zugänglichen Ordner außerhalb von "c:\Programme" legt - bei den Systemdateien ist das leider nicht möglich.

Im Zweifelsfall sollte es aber reichen, nur den Inhalt der virtuellen Verzeichnisse zu löschen.

Was ich allerdings nicht verstehe: Warum das Problem bei Dir erst mit Version 2.0.10 aufgetaucht ist - und warum es nicht überall auftaucht.
Ich habe z.B. unseren "Serverrechner" in Kalbach seit 3 Wintern unter Windows 7 (32Bit) laufen - und auch hier im Büro arbeite ich mit Win 7 (64Bit Ultimate).
Auf das im Wiki geschilderte Problem bin ich aber erst vor Kurzem durch eine Support-Anfrage gestoßen worden...

Ciao

dirk

zatt
Beiträge: 249
Registriert: So Jul 03, 2005 3:08 am
Wohnort: Neubrandenburg
Kontaktdaten:

Re: Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von zatt »

Ist es absehbar, dass diesbezüglich mal ein vernünftiger Installer zum Einsatz kommt?
Außerdem sollte ein Programm(unter)ordner nie als Arbeitsverzeichniss verwendet werden, was in T&F leider immer noch "Default" der Fall ist. :?


cu, Maik

DiWa
Site Admin
Beiträge: 474
Registriert: Mi Sep 21, 2005 9:53 pm
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fehler beim Start von Certificate und bei Neuinstallation

Beitrag von DiWa »

Das wird sich wohl mit Version 3.0 ändern, die in der Entwicklung ist.

Ciao

dirk

Antworten